Disk-on-Disk Manual
1. Manipulation Project

a. Setting up the Amplifiers (more detail can be found in Manipulation Project\Data Sheets\Junus amplifier.pdf and CME2 User Guide.pdf)
i. Find a DC power supply that outputs 20-90V.  Connect the outputs of this to the +HV and GND terminals of the amp using the following diagram:

[image: image1.emf]
Capacitors and diodes can be found in the brown cardboard box labeled capacitors on the middle shelf in the glass cabinet second from the right near Tom's desk.

ii. Download and install CME2 (Copley Motion Explorer2) software from http://www.copleycontrols.com/Motion/Downloads/index.html 

iii. Using the USB to RS-232 cable, connect the amp to your PC.  Install the driver for the HL-340 USB to serial converter (in usb-serial-driver.zip), which creates a virtual serial (COM) port.
iv. Open the program and add the COM port used by the USB to serial cable to the list (the list can be changed later in the Tools -> Communication Wizard menu).

v. Go to Amplifier -> Basic Setup.  Here you choose the different operational modes and input types.
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1. Select Operating Mode: Current.  This means that the input command will control the current being sent to the motor.  If you want to do velocity control then it is preferable to create your own control loop because amp's velocity estimates are less accurate than what you can get from the encoder readings.

2.  Analog Command takes an analog input in the range ±10V and creates an output current proportional to that voltage. [image: image3.png]& Analog Command
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3. PWM Command takes a PWM signal in and creates a current proportional to the duty cycle.  This is done in one of two ways.  50% mode has a 50% duty cycle as the zero current output, with 100% being full forward and 0% being full reverse.  100% mode also requires a second input to determine the direction with 0% being zero current output and 100% being full output, in the chosen direction.  The scaling command determines the maximum output current and should be based on the motor ratings.  [image: image4.png]@ PWM Command =e =
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vi. Click on the Motor button in the block diagram.  Here you can input all the necessary parameters about your motor from the data sheet. [image: image5.png]Motor - Rotary Motor
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vii. Click on the I Loop button and select Auto Tune.  This will automatically find PI controller parameters for your motor.  In the end it will give you several options based on different levels of aggressiveness of the controller. [image: image6.png]& Current Loop.
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With this “optimal” gains of Cp and Ci, you should see the following fine tracking of current by running the menu [Amplifier] – [Scope].
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viii. Click on Input/Output.  Here you can set up the different input and output pins.  I recommend using IN1 as Amp Enable-HI (or LO) Enables With Clear Faults.  This ensures that the motor can only spin when you give it a command.  Choose HI if your digital outputs default to LO, or vice versa. [image: image8.png]& Input/Output.
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ix. Now you just have to wire it up and you are ready to control your motor.  For either input mode, you must connect ground to one or more of the Signal Ground pins (7 or 10-12).  Pin 13 is enable pin.  If using Analog input mode, you will need to connect the analog input to pins 2 and 9.  If using PWM input then you will need to connect the PWM signal to pin 3 and the direction signal to pin 4 (if using 100% mode).  
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x. You are now ready to control your motor.
xi. Other utilities

1. Control Panel (second button from the left in the top menu).  This allows you to software enable/disable the amplifier as well as monitor various inputs/outputs of the motor.
2. Scope (third button from the left in the top menu).  This lets you apply various functions to drive the motor and monitor inputs/outputs over time.  This is useful for making sure your control parameters are working correctly.

b. PIC code (for PWM input).  This can be found in Manipulation Project -> PIC Code.  Comments can be found directly in the code.  This code takes in a trajectory from the user, finds the feedforward control from the motor model, and uses PID control to correct to the nominal trajectory.  The output is a PWM signal to the amplifier.
c. MATLAB code (for PWM input with the PIC).  This can be found in Manipulation Project -> MATLAB Code.  Again comments are in the code.  This is a GUI where the user can enter a trajectory for the motor to follow and send it over to the PIC to be executed.  The user can also request data from the PIC to see how the actual trajectory compares to the nominal.
d. QNX system
i. Outline

[image: image11]
ii. Setup

1. Download QNX Software Development Platform 6.5 from http://www.qnx.com/download/.  UserID: kmlynch@northwestern.edu, password: limslab
Or, use the CD. The license key can be found in [myQNX Account profile] after logging-in.

2. Download a C/C++ of your choice.

iii. Communication and uploading code

1. On the host PC, you need to give it a static IP address.  To do this, go to Control Panel -> Networking and right-click on the ethernet controller and go to Properties.  Find Internet Protocol 4 (TCP/IPv4) in the menu and click on the Properties button below.  Select Use the Following IP Address and enter IP address: 192.168.1.10 (or any other number that isn't taken on the router being used), Subnet mask: 255.255.255.0, and leave the rest blank.
2. The target PC (QNX machine) has the static IP 192.168.1.65.  (The IP address of the target can be changed on the machine by going to the file /etc/system/sysinit and changing it using a text editor; in this file you can also add scripts to be run when the machine is turned on).

3. Either connect the computers directly using a crossover cable or connect both computers to a router.

4. Turn on the PC104 Stack.

5. On the host, open a command prompt window and enter "telnet 192.168.1.65" (or whatever the IP of the target is).  This will connect you to the machine and you should be prompted to enter the login and password, both of which are "root".  NOTE: if you want to use alias for the IP address such as “telnet qnx”, add a line “192.168.1.65 qnx” (spaced by a tab)  in the file  [C:\WINDOWS\system32\drivers\etc\hosts].
6. On the host, open a second command prompt window and go to the directory containing the code you wish to upload to the QNX machine.  For this code, use "cd Desktop" "cd QnxKit_Analysis" ("cd FOLDER" goes into the desired folder, "cd.." goes up one level in the file structure, "ls" shows the contents of the current directory).

7. "make" runs the make file which compiles the project, this will only recompile code that has been changed since the last time it was compiled.  "make clean" will clean out the project so everything is recompiled.  "make put" will act the same way as "make" and also send the executable to the target PC using the wput function (download this if you do not have it and put it in the working directory).

8. If you do not have wput, open another command window and go to the working directory.  Enter "ftp 192.168.1.65" and you will be prompted to log in again.  Now enter "put FILENAME" to transfer the file.

9. Your code is now on the target PC and ready to execute.

10. To run the code, in the first command window (the one where you used telnet), simply type "./FILENAME" (ex. "./qnxkit") and your code will run.

11. NOTE: if you delete the file from the QNX machine, when you put it back on it may not have execute permissions and you will get the error message "cannot execute - Permission denied".  To fix this, use "chmod u=rwx FILENAME" which gives the root user profile (u) read (r), write (w), and execute (x) permissions for the file.  "ls –l" can be used to check permissions for the files in the current directory.

12. NOTE: if you get the message "make: ***No rule to make target 'obj/motor.o', needed by 'qnxkit'. Stop." then make sure the file name of motor.C is actually .C (it sometimes defaults back to .c for unknown reasons).  The same can happen for other functions, but this is the most common.
iv. Changing the code base

1. If you want to add functions to the project, you will need to edit the Makefile.  This can be done in any text editor or C++ editor.
2. In the list of SOURCES, add FILENAME.C (make sure that the file itself is saved as a .C file instead of .c, it is case sensitive).  The header (.h) and object (.o) files will be automatically included in the build.

3. If the IP address of the target is changed, make sure to change the line after "put:" to be the new IP address.

4. If you change the name of your output exectuable, you need to change the TARGET to the new file name.

v. I/O [IoHardware and individual board drivers]
1. The encoder board is the MSI-P404-8, with 8 encoder channels.  Each channel takes in the A and B channels of a single-ended encoder and returns the encoder count using the function GetEncoderCount(); note ProcessInput() must be used first with this function.  The function ReadEncoder() will read the current value and return it to you, it does not need to be used with ProcessInput()
2. The analog input card is the MSI-P414-16, which has 16 analog input lines (12-bit resolution).  To read from a single channel use ReadAnalogCh(ch).  Input range is adjustable in the code and currently set at (10 V. If using ProcessInput(), you can access the resulting arrays using GetAnalogIn(ch).  On the board itself, A is the reference and B is the analog signal.
3. The analog output board is a Ruby-1612-XT (Diamond Systems Corp.), which has 16 analog outputs (12-bit resolution).  To set and output to a single channel, use the function WriteAnalogCh(ch, val).  To set a value to be output, use SetAnalogOut(ch, val); to actually output this value, ProcessOutput() must be called.  The pinout is in the figure below.

[image: image12.emf]


- An example in the code about how to call the functions


For example, when you want to use the first bit of Port A (DIO A0 above) as a digital output, the bit number is 48 in the code (see the figure below)
In [IoHardware.h], you declare enumerator for the bit such that

class IoHardware{



public:



...



// Digital Output pin names



enum DigitalOutputBit{




...




// port A of D I/O 2




DOUT_48 = 48,




…


};
In [SampleLoopTask.C], you call the following function to set the bit high.

HW->WriteDigitalBit(IoHardware::CAMERA_TRIGGER, 1);

Note that the pin numbers on the breakout boards (see the pinout diagram above for the analog board) are different from the pin number used in the code (see the pin numbers on the figure below). For another example, if you’re going to use the second bit of port B of the analog output board, it’s DIO B1, or 39 in the pinout on the breakout board above and use 57 for the pin number to be used in the code.
4. There are 6 digital I/O ports on the 104-DIO-48E digital I/O board (Acces I/O products, inc.) as well as 3 more on the analog output board.  The port and pin structure is shown below, with pin numbers being those referenced in the code, not the pin numbers on the breakout boards.  All of these ports function in the same way, where there are 8 bits that indicate either logic high or low outputs.
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Each port can be set to either an input or an output in the IoHardware::Init() function (all 8 bits are set with the port).  WriteDigitalBit(bit, state) sets and outputs a value while SetDigitalOutBit(bit, state) sets a bit for ProcessOutput() to output.
ReadDigitalBit(bit) reads an input bit while GetDigitalInBit(bit) and GetDebouncedDigitalInBit(bit) get the values read in by ProcessInput().
The pinout for each set of three ports on the dedicated card is found below while the pinout for the 3 ports on the analog output card are above in the analog output section.

[image: image14.emf]
vi. Control loop [SampleLoopTask::Task() in SampleLoopTask.C]
1. The control algorithm is implemented in this loop.
a. The backstepping method is used for the stabilization control (The detailed theory can be found in our technical paper the disk-on-disk.)

b. The backstepping control law finally calculates acceleration command. Another control loop (PID control) to follow this acceleration command is also implemented in the code.
c. There is a feedforward model (found in motor.h/C) that calculates the torque(current) needed to follow the trajectory.
2. The camera triggering and communication happens in this loop
a. For the communication code, see [VisionNet.C, VisionNet.h], which is modified from [MatlabNet.C, h].
b. At the start of the loop, the camera status is read (this will be used later)
c. A trigger pulse is sent to the frame-grabber to take a picture

d. This part is closely related to the vision program running on the vision computer. Once both program start (It will be explained how to start the programs later), the vision program sends the position data of the two dots alternatively.
e. To enable the camera (tell the program to look for coordinates from the camera system), make sure it is toggled on in the user interface.

f. If the camera is on, then the program will wait until the camera status line has toggled, indicating that new coordinates are ready

g. Then the region of interest is read in (default of 2 ROI, this can be changed in the SampleLoopTask.h file)

h. The (x,y) position of the chosen ROI is then stored to the objectInfo structure and the centroid location and orientation of the object is calculated.

i. If there are not coordinates ready by the time a certain counter is reached, then it times out and there is an error message.

j. The vision data sent from the vision computer is in the unit of mm (not meters).

vii. MATLAB communication/data logging [MatlabNet]
1. This opens a TCP/IP socket connection with the host PC

2. Every time through the control loop, the output (num[]) is added to the buffer

3. The number of data points to be sent can be changed in the MatlabNet.h file (#define MATLAB_NET_NUM_CH) and must also be changed in the MATLAB code.

4. To run the MATLAB code, go to the QnxMatlab folder
5. Enter "rtplot" in the command line, a window should pop up.  NOTE: I find that the transmission is most reliable when rtplot is opened after the C++ program on the QNX machine.
6. Click on the start button to begin data collection/plotting.  The "one-shot" check box will make it so that it will only sweep across the screen one time and then stop.  Use this to save data, because when the plot reaches the edge of the screen, it erases the previous data and begins sweeping across again.  This could be modified to save previous data instead of overwriting it.

7. You can create your own plotting functions with customized legends.  For the vision system demo, I used the rtplot_start_vision.m file.  To change which is being used, go to rtplot.m and change the function being called by the start button (line 14 at the end).

8. NOTE: the communication is slightly unreliable; some data is lost in transmission. ( This was maybe because of the low performance host desktop computer. No unreliable communication has been observed since upgrading to a better desktop computer.
9. NOTE: sometimes when this is being run, the transmission will have some sort of error and the readings will go crazy (all you can see is a solid wall of color instead of the expected traces).  When this happens, try stopping and starting the plot again.  If that doesn't work, close the window and reopen rtplot.  If you try that a few times and it still doesn't work, restart the program on the QNX machine and try again.  As a last resort, go into the C++ program and modify it so that it sends less data (send every other time through the loop, or something like that). ( This was maybe because of the low performance host desktop computer. No unreliable communication has been observed since upgrading to a better desktop computer.

viii. Menu

1. a – analog inputs: This asks for an analog input channel, reads that channels, and prints to the screen.
2. g – signal gain: This lets you set the feedback law gains from the default values.  They are updated as soon as you hit enter.

3. o – sample loop overrun: This prints the number of times the SampleLoopTask has overrun the allotted time.  If this is happening, you need to either run at a lower speed or trim down the code.

4. t – timing: This collects data on the amount of time it takes to run through the SampleLoopTask.  You enter a time in seconds and then it outputs the mean, standard deviation, and extreme times.

5. c – camera toggle on (off): This tells the program to start looking for data from the camera.  The trigger pulse is always being sent but nothing is happening with the inputs until this option is turned on.

6. m – disable (enable) motor: This option changes the hardware enable pin on the amplifier to disable (enable) the motor. The default (when the program starts) value is disable. So, the actual control action occurs when toggles this menu.
7. q – quit: This options ends the program.

8. h – print menu: This option prints the menu to screen again.

ix. Subversion (SVN)

1. This is the program that uploads and downloads the latest code from the Google code page.
2. Right click on the folder and select SVN Update to get the latest code from the server.

3. Right click on the folder and select SVN Commit to upload your code to the server.

4. The Google code page is at http://code.google.com/p/limsqnx/; there you can look at the sources files and look at previous revisions.

x. Other Issues

1. Encoder readings: Sometimes the encoder from the motor is not read in properly, it appears to just stop reading for short periods of time.  I find that this happens more often when running at high speeds and when the command current is high.  
e. Running the program
i. [Vision calibration] After mounting the camera, you must do the calibration. Due to the way the program is coded, you also need to find the center position of the upper disk at the upright position. This will be explained in more detail in this manual or a separate manual.
ii. Run the qnx program by typing ./qnxkit [image: image15.png]o home directory.
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iii. Run the vision program on the vision computer by opening \QNX Tracking\QNX Tracking.sln.  Run F5 on [qnx tracking.cpp]. 

iv. Then click the two dots to be tracked and press ‘q’.

v. On the qnx interface, select ‘c’, then it starts to calculate the control command.
vi. By pressing ‘m’, the motor will be enabled and start to run the control action.

vii. If something goes wrong with the motor, press ‘q’ to quit the program.

f. Vision system setting
i. As of 4/3/2013, the DIO board of the PC104 stack is not working. So, I’m using the Digital port of the Analog Output board for the camera trigger signal (output) and frame status signal (input).  See [IoHardware.h]. 
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